aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-29 11:12:49 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-29 11:12:49 +0100
commit0895002f68a51de2c237e1fe83ec6e4ffc980eff (patch)
tree34b1dbfafef2e98892c793c2001f028d1e88efd0 /gnu/packages/rust-apps.scm
parent333d15790caec5c6782c3889a29b6f91d40ac42d (diff)
parent602059e794182a035f3919c3eb88d7d2085e24df (diff)
downloadpatches-0895002f68a51de2c237e1fe83ec6e4ffc980eff.tar
patches-0895002f68a51de2c237e1fe83ec6e4ffc980eff.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm16
1 files changed, 1 insertions, 15 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 8ad3c0ced4..90bd146442 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -143,21 +143,7 @@ gitignore rules.")
(add-after 'configure 'unvendor-libraries-from-crates
(lambda* (#:key inputs #:allow-other-keys)
(let ((openssl (assoc-ref inputs "openssl")))
- (setenv "OPENSSL_DIR" openssl)
- (setenv "LIBGIT2_SYS_USE_PKG_CONFIG" "1")
- (setenv "LIBSSH2_SYS_USE_PKG_CONFIG" "1")
- (delete-file-recursively
- (string-append "guix-vendor/rust-libgit2-sys-"
- ,(package-version rust-libgit2-sys-0.10)
- ".crate/libgit2"))
- (delete-file-recursively
- (string-append "guix-vendor/rust-libssh2-sys-"
- ,(package-version rust-libssh2-sys-0.2)
- ".crate/libssh2"))
- (delete-file-recursively
- (string-append "guix-vendor/rust-libz-sys-"
- ,(package-version rust-libz-sys-1.0)
- ".crate/src/zlib")))
+ (setenv "OPENSSL_DIR" openssl))
#t)))))
(native-inputs
`(("libgit2" ,libgit2)