summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-11 23:36:36 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-14 00:18:08 +0100
commit3cc8e029a08f33f6fd8d033e46f56efe499de563 (patch)
treed9493a850c70b1e3c35dad7d7960aed772941ab4 /gnu/packages/ruby.scm
parent3963fc70a52e9ebdd0639870a60ec786c59aaca3 (diff)
downloadpatches-3cc8e029a08f33f6fd8d033e46f56efe499de563.tar
patches-3cc8e029a08f33f6fd8d033e46f56efe499de563.tar.gz
gnu: Add ruby-hydra.
* gnu/packages/ruby.scm (ruby-hydra): New public variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm36
1 files changed, 35 insertions, 1 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 57d7fa91f3..969fc95a00 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017 ng0 <ng0@n0.is>
-;;; Copyright © 2017, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
@@ -1953,6 +1953,40 @@ two hashes.")
(home-page "https://github.com/liufengyun/hashdiff")
(license license:expat)))
+(define-public ruby-hydra
+ ;; No releases yet.
+ (let ((commit "5abfa378743756ae4d9306cc134bcc482f5c9525")
+ (revision "0"))
+ (package
+ (name "ruby-hydra")
+ (version (git-version "0.0" revision commit))
+ (home-page "https://github.com/hyphenation/hydra")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1cik398l2765y3d9sdhjzki3303hkry58ac6jlkiy7iy62nm529f"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'make-files-writable
+ (lambda _
+ (for-each make-file-writable (find-files "."))
+ #t))
+ (replace 'check
+ (lambda _
+ (invoke "rspec"))))))
+ (native-inputs
+ `(("ruby-rspec" ,ruby-rspec)))
+ (propagated-inputs
+ `(("ruby-byebug" ,ruby-byebug)))
+ (synopsis "Ruby hyphenation patterns")
+ (description
+ "ruby-hydra is a Ruby library for working with hyphenation patterns.")
+ (license license:expat))))
+
(define-public ruby-shindo
(package
(name "ruby-shindo")