summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-27 09:27:35 +0000
committerChristopher Baines <mail@cbaines.net>2019-02-14 21:37:55 +0000
commitf7e9b2f37541e6863dc72c924148fa6ed28b39c1 (patch)
treea1688fe8372f823f8359b06d7fa265273d585139 /gnu/packages/ruby.scm
parent1d1d20b02b3e01c01e41796d4329ab53afbad98e (diff)
downloadpatches-f7e9b2f37541e6863dc72c924148fa6ed28b39c1.tar
patches-f7e9b2f37541e6863dc72c924148fa6ed28b39c1.tar.gz
gnu: Add ruby-backports.
* gnu/packages/ruby.scm (ruby-backports): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5ba68fee2f..43e640405f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1369,6 +1369,31 @@ User Agents.")
(home-page "https://github.com/gshutler/useragent")
(license license:expat)))
+(define-public ruby-backports
+ (package
+ (name "ruby-backports")
+ (version "3.11.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "backports" version))
+ (sha256
+ (base32
+ "1hshjxww2h7s0dk57njrygq4zpp0nlqrjfya7zwm27iq3rhc3y8g"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(;; TODO: This should be default, but there is one test failure
+ #:test-target "all_spec"))
+ (native-inputs
+ `(("ruby-mspec" ,ruby-mspec)
+ ("ruby-activesupport" ,ruby-activesupport)))
+ (synopsis "Backports of the features in newer Ruby versions")
+ (description
+ "Backports enables more compatibility across Ruby versions by providing
+backports of some features.")
+ (home-page "https://github.com/marcandre/backports")
+ (license license:expat)))
+
(define-public ruby-bacon
(package
(name "ruby-bacon")