summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-27 16:42:45 +0000
committerChristopher Baines <mail@cbaines.net>2019-02-14 21:37:57 +0000
commitbef3506eb8cb04df812c9d36f2dc51efe95dd7b5 (patch)
tree11412f14ea4f4a3ebfd19201bc0458547b92e2a5 /gnu/packages/ruby.scm
parentd5840f77252d662da403a423f8f2cf947d1c712d (diff)
downloadpatches-bef3506eb8cb04df812c9d36f2dc51efe95dd7b5.tar
patches-bef3506eb8cb04df812c9d36f2dc51efe95dd7b5.tar.gz
gnu: Add ruby-cliver.
Requirement of ruby-parser. * gnu/packages/ruby.scm (ruby-cliver): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d55daaa310..d3d1c5268c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -890,6 +890,40 @@ code in Merb and Rails.")
(home-page "https://github.com/jnunemaker/crack")
(license license:expat)))
+(define-public ruby-cliver
+ (package
+ (name "ruby-cliver")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "cliver" version))
+ (sha256
+ (base32
+ "096f4rj7virwvqxhkavy0v55rax10r4jqf8cymbvn4n631948xc7"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; Avoid a incompatibility between rspec@2 and rake. Using rspec@3
+ ;; would be nice, but the tests look to be incompatible:
+ ;;
+ ;; NoMethodError: undefined method `last_comment'
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "rspec"))
+ #t)))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec-2)))
+ (synopsis "Assertions for command-line dependencies in Ruby")
+ (description
+ "@code{cliver} provides a way to detect missing command-line
+dependencies, including versions.")
+ (home-page "https://github.com/yaauie/cliver")
+ (license license:expat)))
+
(define-public ruby-czmq-ffi-gen
(package
(name "ruby-czmq-ffi-gen")