summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-27 16:43:32 +0000
committerChristopher Baines <mail@cbaines.net>2019-02-14 21:37:58 +0000
commit433f10b5d2d7714440e92b7f563fb51dea7779f4 (patch)
treebe9e6e89716cbd9be624cdd4448c13065ba41a0d /gnu/packages/ruby.scm
parentd8c189ed56d20c2eeb52710b197f52b3472103c8 (diff)
downloadpatches-433f10b5d2d7714440e92b7f563fb51dea7779f4.tar
patches-433f10b5d2d7714440e92b7f563fb51dea7779f4.tar.gz
gnu: Add ruby-jaro-winkler.
Required for ruby-rubocop. * gnu/packages/ruby.scm (ruby-jaro-winkler): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 06f6fffbf3..73147983ff 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3352,6 +3352,29 @@ when working with Ruby code.")
;; There is no mention of the "or later" clause.
(license license:gpl2)))
+(define-public ruby-jaro-winkler
+ (package
+ (name "ruby-jaro-winkler")
+ (version "1.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "jaro_winkler" version))
+ (sha256
+ (base32
+ "1zz27z88qznix4r65gd9h56gl177snlfpgv10b0s69vi8qpl909l"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(;; No included tests
+ #:tests? #f))
+ (synopsis "Ruby implementation of Jaro-Winkler distance algorithm")
+ (description
+ "@code{jaro_winkler} is an implementation of Jaro-Winkler distance
+algorithm. It is written as a C extension and will fallback to a pure Ruby
+implementation on platforms where this is unsupported.")
+ (home-page "https://github.com/tonytonyjan/jaro_winkler")
+ (license license:expat)))
+
(define-public ruby-json
(package
(name "ruby-json")