summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorPjotr Prins <pjotr.public12@thebird.nl>2015-09-16 06:06:40 +0200
committerDavid Thompson <dthompson2@worcester.edu>2015-09-19 08:34:14 -0400
commit6aaa815e9fae8fccb98c243936210c17cd9609ed (patch)
treec84ea4e97b0210a317abd326f3b6152ce5ef5a73 /gnu/packages/ruby.scm
parent8874f7668ae93bec2805fd823bfcbe80a977e78c (diff)
downloadpatches-6aaa815e9fae8fccb98c243936210c17cd9609ed.tar
patches-6aaa815e9fae8fccb98c243936210c17cd9609ed.tar.gz
gnu: Add ruby-docile.
* gnu/packages/ruby.scm (ruby-docile): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index fa4f345882..9c081624b6 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1149,6 +1149,27 @@ into a single method call.")
(home-page "http://rack.github.io/")
(license license:expat)))
+(define-public ruby-docile
+ (package
+ (name "ruby-docile")
+ (version "1.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "docile" version))
+ (sha256
+ (base32
+ "0m8j31whq7bm5ljgmsrlfkiqvacrw6iz9wq10r3gwrv5785y8gjx"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; needs github-markup, among others
+ (synopsis "Ruby EDSL helper library")
+ (description "Docile is a Ruby library that provides an interface for
+creating embedded domain specific languages (EDSLs) that manipulate existing
+Ruby classes.")
+ (home-page "https://ms-ati.github.io/docile/")
+ (license license:expat)))
+
(define-public ruby-gherkin3
(package
(name "ruby-gherkin3")