summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-01-13 19:58:56 +0000
committerChristopher Baines <mail@cbaines.net>2020-01-14 23:40:46 +0000
commit740fea08727fc300f530e00fab49a57e984387cb (patch)
tree454b84a34e15099ca2a744c748aa7b1cb16d0bd6 /gnu/packages/ruby.scm
parent1c65d99f1b455ac06c6e30594aa4d8243d36b8b6 (diff)
downloadpatches-740fea08727fc300f530e00fab49a57e984387cb.tar
patches-740fea08727fc300f530e00fab49a57e984387cb.tar.gz
gnu: ruby-tzinfo: Skip safe tests.
The safe tests attempt to run with Ruby 2.6, but these tests fail if the build takes place within /tmp, as the Ruby LOAD_PATH then includes /tmp, which is world writable. * gnu/packages/ruby.scm (ruby-tzinfo)[arguments]: Add skip-safe-tests phase.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 34c7b9c157..95d29850b5 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4108,6 +4108,16 @@ utilities for Ruby.")
(base32
"09dpbrih054mn42flbbcdpzk2727mzfvjrgqb12zdafhx7p9rrzp"))))
(build-system ruby-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-safe-tests
+ (lambda _
+ (substitute* "test/test_utils.rb"
+ (("def safe_test\\(options = \\{\\}\\)")
+ "def safe_test(options = {})
+ skip('The Guix build environment has an unsafe load path')"))
+ #t)))))
(propagated-inputs
`(("ruby-thread-safe" ,ruby-thread-safe)))
(synopsis "Time zone library for Ruby")