summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-11-23 22:24:52 -0500
committerLeo Famulari <leo@famulari.name>2016-11-23 22:24:52 -0500
commit2ac7d54616819c65405ea27260dbff462160f290 (patch)
tree4c82001f0855ebab05ab342e342a680c533b9bf9 /gnu/packages/ruby.scm
parent61320932edb42e78fb377b5d11cd6ecb32e2f9e6 (diff)
parent1c9f78eca1f7e169562abaaa882fd94d845208af (diff)
downloadpatches-2ac7d54616819c65405ea27260dbff462160f290.tar
patches-2ac7d54616819c65405ea27260dbff462160f290.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 24 insertions, 2 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 31eb8dfc6a..6471f2ff45 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -102,7 +102,7 @@ a focus on simplicity and productivity.")
(define-public ruby-2.2
(package (inherit ruby)
- (version "2.2.5")
+ (version "2.2.6")
(source
(origin
(method url-fetch)
@@ -111,7 +111,7 @@ a focus on simplicity and productivity.")
"/ruby-" version ".tar.xz"))
(sha256
(base32
- "1mw7bzw76g5w37cwhb57r6gxcl2vn9lfrlyf4h4xms3qlnhflvzq"))))))
+ "0fbk2pyjphynj4kxn27vb5rsq6brr3y85p784jd1rxwws30fq54l"))))))
(define-public ruby-2.1
(package (inherit ruby)
@@ -4178,3 +4178,25 @@ patterns.")
libraries for compiling Ruby native extensions.")
(home-page "https://github.com/ruby-gnome2/pkg-config")
(license license:lgpl2.0+)))
+
+(define-public ruby-net-http-digest-auth
+ (package
+ (name "ruby-net-http-digest-auth")
+ (version "1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "net-http-digest_auth" version))
+ (sha256
+ (base32
+ "14801gr34g0rmqz9pv4rkfa3crfdbyfk6r48vpg5a5407v0sixqi"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("ruby-hoe" ,ruby-hoe)))
+ (synopsis "RFC 2617 HTTP digest authentication library")
+ (description
+ "This library implements HTTP's digest authentication scheme based on
+RFC 2617. This enables the use of the digest authentication scheme instead
+of the more insecure basic authentication scheme.")
+ (home-page "http://github.com/drbrain/net-http-digest_auth")
+ (license license:expat)))