summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-09-27 22:18:33 +1000
committerChristopher Baines <mail@cbaines.net>2017-09-30 11:46:09 +0100
commit9b4c8e1b72c2308b515dcafcf3330c10319f13eb (patch)
tree38b3ab86a547235c619304435f17b196bafdfa6f /gnu/packages/ruby.scm
parentcef87ed6bea8e86cf50c77275b15e73b28fefb9e (diff)
downloadpatches-9b4c8e1b72c2308b515dcafcf3330c10319f13eb.tar
patches-9b4c8e1b72c2308b515dcafcf3330c10319f13eb.tar.gz
gnu: Add ruby-code-statistics.
* gnu/packages/ruby.scm (ruby-code-statistics): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ec4d33f401..283f393b82 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4376,3 +4376,24 @@ really opens up the email messages you are parsing, if you know what you
are doing, you can fiddle with every last bit of your email directly.")
(home-page "https://github.com/mikel/mail")
(license license:expat)))
+
+(define-public ruby-code-statistics
+ (package
+ (name "ruby-code-statistics")
+ (version "0.2.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "code_statistics" version))
+ (sha256
+ (base32
+ "07rdpsbwbmh4vp8nxyh308cj7am2pbrfhv9v5xr2d5gq8hnnsm93"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; Not all test code is included in gem.
+ (synopsis "Port of the rails 'rake stats' method")
+ (description
+ "This gem is a port of the rails 'rake stats' method so it can be made
+more robust and work for non rails projects.")
+ (home-page "http://github.com/danmayer/code_statistics")
+ (license license:expat)))