summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-19 01:50:19 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-19 01:50:19 +0100
commit02f21a874ea11b2eab50d64147908eacf16f2968 (patch)
tree735f9f1aa2da476e96ccd038038a5b942f86954e /gnu/packages/ruby.scm
parent4a158286a683d5f599b829f797fc5e8e997af06d (diff)
downloadpatches-02f21a874ea11b2eab50d64147908eacf16f2968.tar
patches-02f21a874ea11b2eab50d64147908eacf16f2968.tar.gz
gnu: ruby: Remove graft for 2.4.3.
* gnu/packages/ruby.scm (ruby): Update to 2.4.3. (ruby-2.4.3): Remove variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 2 insertions, 23 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 776f84e07a..0ed29f7fad 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -50,8 +50,7 @@
(define-public ruby
(package
(name "ruby")
- (replacement ruby-2.4.3)
- (version "2.4.2")
+ (version "2.4.3")
(source
(origin
(method url-fetch)
@@ -60,7 +59,7 @@
"/ruby-" version ".tar.xz"))
(sha256
(base32
- "0dgp4ypk3smrsbh2c249n5pl6nqhpd2igq9484dbsh81sf08k2kl"))
+ "0l9bv67dgsphk42lmiskhrnh47hbyj6rfg2rcjx22xivpx07srr3"))
(modules '((guix build utils)))
(snippet `(begin
;; Remove bundled libffi
@@ -104,26 +103,6 @@ a focus on simplicity and productivity.")
(home-page "https://ruby-lang.org")
(license license:ruby)))
-(define-public ruby-2.4.3
- (package
- (inherit ruby)
- (name "ruby")
- (version "2.4.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "http://cache.ruby-lang.org/pub/ruby/"
- (version-major+minor version)
- "/ruby-" version ".tar.xz"))
- (sha256
- (base32
- "0l9bv67dgsphk42lmiskhrnh47hbyj6rfg2rcjx22xivpx07srr3"))
- (modules '((guix build utils)))
- (snippet `(begin
- ;; Remove bundled libffi
- (delete-file-recursively "ext/fiddle/libffi-3.2.1")
- #t))))))
-
(define-public ruby-2.3
(package
(inherit ruby)