summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-12-29 14:13:42 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-01-26 15:59:39 +1000
commit7c8131c76b3a7e5bb0f133c554b46960b3430b70 (patch)
treea3cd4add2ea0bd211dbac72004ed297a9b81a3e5 /gnu/packages/ruby.scm
parenta78d62f4323bac9d93bda73cfb4251c47f6675c9 (diff)
downloadpatches-7c8131c76b3a7e5bb0f133c554b46960b3430b70.tar
patches-7c8131c76b3a7e5bb0f133c554b46960b3430b70.tar.gz
gnu: Add ruby-rubytest.
* gnu/packages/ruby.scm (ruby-rubytest): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f7a20b864c..17dfd4a86e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2994,3 +2994,34 @@ to the @code{STDOUT} and @code{STDERR} streams are reported, giving extra
detail to ease debugging.")
(home-page "http://github.com/wwood/bioruby-commandeer")
(license license:expat)))
+
+(define-public ruby-rubytest
+ (package
+ (name "ruby-rubytest")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rubytest" version))
+ (sha256
+ (base32
+ "19jydsdnkl81i9dhdcr4dc34j0ilm68ff2ngnka1hi38xiw4p5qz"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; Disable regular testing to break the cycle rubytest, qed, brass,
+ ;; rubytest, as well as the cycle rubytest, qed, ansi, rubytest. Instead
+ ;; simply test that the library can be require'd.
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "ruby" "-Ilib" "-r" "rubytest")))))))
+ (propagated-inputs
+ `(("ruby-ansi" ,ruby-ansi)))
+ (synopsis "Universal test harness for Ruby")
+ (description
+ "Rubytest is a testing meta-framework for Ruby. It can handle any
+compliant test framework and can run tests from multiple frameworks in a
+single pass.")
+ (home-page "http://rubyworks.github.io/rubytest")
+ (license license:bsd-2)))