summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-07-24 21:56:47 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-07-24 22:04:44 +0200
commit45498f51be5e0d747e69b2891a331fe7cadb1df4 (patch)
tree586389d5b2fc1af536114a556389e0b47ae43b7f /gnu/packages/ruby.scm
parent8440db459a10daa24282038f35bc0b6771bd51ab (diff)
downloadpatches-45498f51be5e0d747e69b2891a331fe7cadb1df4.tar
patches-45498f51be5e0d747e69b2891a331fe7cadb1df4.tar.gz
gnu: Add ruby-childprocess.
* gnu/packages/ruby.scm (ruby-childprocess): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9a74f16c01..bd8df1a349 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4983,3 +4983,28 @@ Markdown.")
in standard Ruby syntax.")
(home-page "https://github.com/ruby/rake")
(license license:expat)))
+
+(define-public ruby-childprocess
+ (package
+ (name "ruby-childprocess")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "childprocess" version))
+ (sha256
+ (base32
+ "0a61922kmvcxyj5l70fycapr87gz1dzzlkfpq85rfqk5vdh3d28p"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)))
+ (propagated-inputs
+ `(("ruby-ffi" ,ruby-ffi)))
+ (synopsis "Control external programs running in the background, in Ruby")
+ (description "@code{childprocess} provides a gem to control external
+programs running in the background, in Ruby.")
+ (home-page "http://github.com/enkessler/childprocess")
+ (license license:expat)))