summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 16:48:39 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:08:42 +0200
commitfa0063bcf437e375d32126d33fa5f1d1044e8b08 (patch)
tree36be1a2cb2ab9af9ade9850c7cfb1aebf0afb811 /gnu/packages/ruby.scm
parent0312706955d9b790671af4c8553bf70cf07057d0 (diff)
downloadpatches-fa0063bcf437e375d32126d33fa5f1d1044e8b08.tar
patches-fa0063bcf437e375d32126d33fa5f1d1044e8b08.tar.gz
gnu: Add ruby-http-parser.rb.
* gnu/packages/ruby.scm (ruby-http-parser.rb): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f7688aa51a..93772d9300 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5634,3 +5634,27 @@ of Markdown. It is completely written in Ruby, supports standard Markdown
(with some minor modifications) and various extensions that have been made
popular by the PHP @code{Markdown Extra} package and @code{Maruku}.")
(license license:expat)))
+
+(define-public ruby-http-parser.rb
+ (package
+ (name "ruby-http-parser.rb")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "http_parser.rb" version))
+ (sha256
+ (base32
+ "15nidriy0v5yqfjsgsra51wmknxci2n2grliz78sf9pga3n0l7gi"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; No tests
+ `(#:tests? #f))
+ (native-inputs
+ `(("ruby-rake-compiler" ,ruby-rake-compiler)
+ ("ruby-rspec" ,ruby-rspec)))
+ (home-page "https://github.com/tmm1/http_parser.rb")
+ (synopsis "HTTP parser un Ruby")
+ (description "This gem is a simple callback-based HTTP request/response
+parser for writing http servers, clients and proxies.")
+ (license license:expat)))