summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 16:55:00 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:08:44 +0200
commit5e2f74bdb847db3b4dd429efcacd6dd4432a771b (patch)
treee09643b85bc529e9b39aa3eb4aaa1f458cc3aef4 /gnu/packages/ruby.scm
parentfa0063bcf437e375d32126d33fa5f1d1044e8b08 (diff)
downloadpatches-5e2f74bdb847db3b4dd429efcacd6dd4432a771b.tar
patches-5e2f74bdb847db3b4dd429efcacd6dd4432a771b.tar.gz
gnu: Add ruby-em-websocket.
* gnu/packages/ruby.scm (ruby-em-websocket): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 93772d9300..024a99ab4c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5658,3 +5658,30 @@ popular by the PHP @code{Markdown Extra} package and @code{Maruku}.")
(description "This gem is a simple callback-based HTTP request/response
parser for writing http servers, clients and proxies.")
(license license:expat)))
+
+(define-public ruby-em-websocket
+ (package
+ (name "ruby-em-websocket")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "em-websocket" version))
+ (sha256
+ (base32
+ "1bsw8vjz0z267j40nhbmrvfz7dvacq4p0pagvyp17jif6mj6v7n3"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; No tests
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-eventmachine" ,ruby-eventmachine)
+ ("ruby-http-parser.rb" ,ruby-http-parser.rb)))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)))
+ (home-page "https://github.com/igrigorik/em-websocket")
+ (synopsis "EventMachine based WebSocket server")
+ (description "Em-websocket is an EventMachine based WebSocket server
+implementation.")
+ (license license:expat)))