summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2015-06-13 07:53:23 -0400
committerDavid Thompson <davet@gnu.org>2015-06-15 20:27:38 -0400
commit71d3e2c28de72fe4de5df36a5df19a79cfe0d9d7 (patch)
tree86785d0ba620cc82075dddfdaae4cd88145da767 /gnu/packages/ruby.scm
parent66e2086364c7efb034b6044cef3bcad1f3b676b2 (diff)
downloadpatches-71d3e2c28de72fe4de5df36a5df19a79cfe0d9d7.tar
patches-71d3e2c28de72fe4de5df36a5df19a79cfe0d9d7.tar.gz
gnu: Add ruby-slop.
* gnu/packages/ruby.scm (ruby-slop): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b0192946d1..45175df170 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -620,3 +620,25 @@ run as a daemon and to be controlled by simple start/stop/restart commands.")
and manipulate Git repositories by wrapping system calls to the git binary.")
(home-page "https://github.com/schacon/ruby-git")
(license license:expat)))
+
+(define-public ruby-slop
+ (package
+ (name "ruby-slop")
+ (version "4.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/leejarvis/slop/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0cqs50a0b99kjd19xpln8jpnki07cjyp3l7wxbfr44ycasr6nznh"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("ruby-minitest" ,ruby-minitest)))
+ (synopsis "Ruby command line option parser")
+ (description "Slop provides a Ruby domain specific language for gathering
+options and parsing command line flags.")
+ (home-page "https://github.com/leejarvis/slop")
+ (license license:expat)))