summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2015-06-05 16:50:24 -0400
committerDavid Thompson <davet@gnu.org>2015-06-15 20:27:38 -0400
commit4c0aeb44d605863466bbf90386bfaa88c590a5aa (patch)
treee70e562a65a907ce8ee4e82980cb6f4f10722f74 /gnu/packages/ruby.scm
parente259bdf008f28924cc97edaede3b4a7caf4502ad (diff)
downloadpatches-4c0aeb44d605863466bbf90386bfaa88c590a5aa.tar
patches-4c0aeb44d605863466bbf90386bfaa88c590a5aa.tar.gz
gnu: Add ruby-net-http-persistent.
* gnu/packages/ruby.scm (ruby-net-http-persistent): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e7b3c5d247..31a377bb20 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -438,3 +438,30 @@ implementations.")
interface for Ruby programs.")
(home-page "https://github.com/mperham/connection_pool")
(license license:expat)))
+
+(define-public ruby-net-http-persistent
+ (package
+ (name "ruby-net-http-persistent")
+ (version "2.9.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/drbrain/net-http-persistent/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1q18vji31w8gfr6ajziqkqs8n5lzkw0bl00dm2a8s05zhavzw9j9"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'build ; no gemspec
+ (lambda _ (zero? (system* "rake" "gem")))))))
+ (native-inputs
+ `(("ruby-connection-pool" ,ruby-connection-pool)
+ ("ruby-hoe" ,ruby-hoe)))
+ (synopsis "Persistent HTTP connection manager")
+ (description "Net::HTTP::Persistent manages persistent HTTP connections
+using Net::HTTP, supporting reconnection and retry according to RFC 2616.")
+ (home-page "https://github.com/drbrain/net-http-persistent")
+ (license license:expat)))