summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-04 23:33:15 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:02 +0200
commite405f996e9eea26ee21bdb3d5c13ab4930454e9a (patch)
treee76c10143dbcb376c3cdf5a15ba8b2833d22d917 /gnu/packages/ruby.scm
parent60306e451721c36915dd4f5332996cb8aa53c1f8 (diff)
downloadpatches-e405f996e9eea26ee21bdb3d5c13ab4930454e9a.tar
patches-e405f996e9eea26ee21bdb3d5c13ab4930454e9a.tar.gz
gnu: ruby-net-scp: Don't use unstable tarball.
* gnu/packages/ruby.scm (ruby-net-scp)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9a899b6bb4..2412244e43 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2986,12 +2986,13 @@ with processes on remote servers, via SSH2.")
(version "1.2.2.rc2")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/net-ssh/net-scp/archive/v"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/net-ssh/net-scp.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0xyf17mhgvyz54xjj9ria4wnq3x62bhmkfgzqv8jwiip2bplv1nk"))))
+ (base32 "1nyn17sy71fn7zs3y6wbgcn35318c10flqgc0582409095x4h0sx"))))
(build-system ruby-build-system)
(native-inputs
`(("bundler" ,bundler)