summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-02-17 17:24:05 +0000
committerChristopher Baines <mail@cbaines.net>2019-03-23 09:56:37 +0000
commit09924294333881315f5a21280c07f01c0313425f (patch)
tree22c9903bc1a6ca44a6e4f7354480c2e23a6d200c /gnu/packages/ruby.scm
parent1d672a6a7518d8a5d904429145ce182946076068 (diff)
downloadpatches-09924294333881315f5a21280c07f01c0313425f.tar
patches-09924294333881315f5a21280c07f01c0313425f.tar.gz
gnu: Add ruby-rerun.
* gnu/packages/ruby.scm (ruby-rerun): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9567f48877..9a899b6bb4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2852,6 +2852,30 @@ conversion to (X)HTML.")
(home-page "https://github.com/vmg/redcarpet")
(license license:expat)))
+(define-public ruby-rerun
+ (package
+ (name "ruby-rerun")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rerun" version))
+ (sha256
+ (base32
+ "1cskvxk8z8vmfail8na7hj91hs0qnvds9nydj04zi3dbddgnbmvz"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; No included tests
+ (propagated-inputs
+ `(("ruby-listen" ,ruby-listen)))
+ (synopsis "Run a process, and restart when some monitored files change")
+ (description
+ "Rerun is a tool to launch programs, then monitor the filesystem, and
+restart the program when any of the monitored files change. It's written in
+Ruby, but can be used for all programs.")
+ (home-page "https://github.com/alexch/rerun/")
+ (license license:expat)))
+
(define-public ruby-mocha
(package
(name "ruby-mocha")