summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-28 22:50:23 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-28 22:55:06 +0200
commit3d30c3321089c460d35f8bf09a435cc22a604477 (patch)
treebd7355b525a9dc44c0a27b1cb452f530273c6298 /gnu/packages/ruby.scm
parent11d1b31807f283cbb93609853c6132e26a9eb6b8 (diff)
downloadpatches-3d30c3321089c460d35f8bf09a435cc22a604477.tar
patches-3d30c3321089c460d35f8bf09a435cc22a604477.tar.gz
gnu: ruby-ansi: Don't use unstable tarball.
* gnu/packages/ruby.scm (ruby-ansi)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0d64e05494..c95123d432 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6578,14 +6578,15 @@ requests either using arguments or with an interactive prompt.")
(version "1.5.0")
(source
(origin
- (method url-fetch)
+ (method git-fetch)
;; Fetch from GitHub as the gem does not contain testing code.
- (uri (string-append "https://github.com/rubyworks/ansi/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (git-reference
+ (url "https://github.com/rubyworks/ansi")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1zdip30hivyipi8hndhb457bhiz033awd00bgrsk5axjrwp6zhly"))))
+ "1wsz7xxwl3vkh277jb7fd7akqnqqgbvalxzpjwniiqk8ghfprbi5"))))
(build-system ruby-build-system)
(arguments
`(#:phases
@@ -6616,7 +6617,7 @@ methods, a @code{Mixin} module for including color methods, a @code{Logger}, a
@code{ProgressBar}, and a @code{String} subclass. The library also includes a
@code{Terminal} module which provides information about the current output
device.")
- (home-page "https://rubyworks.github.io/ansi")
+ (home-page "https://rubyworks.github.io/ansi/")
(license license:bsd-2)))
(define-public ruby-systemu