aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/rsync.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-20 17:36:56 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-20 17:36:56 +0100
commit7f69459aca16756f35f08049c64a1bd77d23f33e (patch)
tree1d267fb62feab89de5d97582672540cbaa37392c /gnu/packages/rsync.scm
parent4a82722a658220ec1e10f9f2d5d77407d38db90e (diff)
parentb1989c12501e880afab62d3ff961791906fef350 (diff)
downloadpatches-7f69459aca16756f35f08049c64a1bd77d23f33e.tar
patches-7f69459aca16756f35f08049c64a1bd77d23f33e.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/rsync.scm')
-rw-r--r--gnu/packages/rsync.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/rsync.scm b/gnu/packages/rsync.scm
index d7fc188af2..4fed03523e 100644
--- a/gnu/packages/rsync.scm
+++ b/gnu/packages/rsync.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,22 +33,14 @@
(define-public rsync
(package
(name "rsync")
- (version "3.1.2")
+ (version "3.1.3")
(source (origin
(method url-fetch)
(uri (string-append "http://rsync.samba.org/ftp/rsync/src/rsync-"
version ".tar.gz"))
(sha256
(base32
- "1hm1q04hz15509f0p9bflw4d6jzfvpm1d36dxjwihk1wzakn5ypc"))
- (patches (search-patches "rsync-CVE-2017-16548.patch"
- "rsync-CVE-2017-17433.patch"
- "rsync-CVE-2017-17433-fix-tests.patch"
- "rsync-CVE-2017-17434-pt1.patch"
- "rsync-CVE-2017-17434-pt2.patch"
- ))
- ))
- (properties `((lint-hidden-cve . ("CVE-2017-15994")))) ; introduced after 3.1.2
+ "1h0011dj6jgqpgribir4anljjv7bbrdcs8g91pbsmzf5zr75bk2m"))))
(build-system gnu-build-system)
(inputs `(("perl" ,perl)
("acl" ,acl)))