summaryrefslogtreecommitdiff
path: root/gnu/packages/regex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 13:37:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:37:36 +0100
commited5900890ef8ed5635e8bc6aa9f8571926e7169d (patch)
treeb89b7f605b15abedde6b6309f189f4b3d1e2b3ce /gnu/packages/regex.scm
parent4255818d1c3993988b3351d57db6e057a867f549 (diff)
downloadpatches-ed5900890ef8ed5635e8bc6aa9f8571926e7169d.tar
patches-ed5900890ef8ed5635e8bc6aa9f8571926e7169d.tar.gz
gnu: tre: Use INVOKE.
* gnu/packages/regex.scm (tre)[arguments]: Use INVOKE.
Diffstat (limited to 'gnu/packages/regex.scm')
-rw-r--r--gnu/packages/regex.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/regex.scm b/gnu/packages/regex.scm
index f526d1c237..bfd30278e9 100644
--- a/gnu/packages/regex.scm
+++ b/gnu/packages/regex.scm
@@ -91,9 +91,9 @@ Python. It is a C++ library.")
;; The tests require the availability of the
;; 'en_US.ISO-8859-1' locale.
(setenv "LOCPATH" (getcwd))
- (zero? (system* "localedef" "--no-archive"
- "--prefix" (getcwd) "-i" "en_US"
- "-f" "ISO-8859-1" "./en_US.ISO-8859-1")))))))
+ (invoke "localedef" "--no-archive"
+ "--prefix" (getcwd) "-i" "en_US"
+ "-f" "ISO-8859-1" "./en_US.ISO-8859-1"))))))
(synopsis "Approximate regex matching library and agrep utility")
(description "Superset of the POSIX regex API, enabling approximate
matching. Also ships a version of the agrep utility which behaves similar to