summaryrefslogtreecommitdiff
path: root/gnu/packages/rdf.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-05-02 22:42:53 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-02 22:42:53 +0200
commitb9212a5455304661d1e969ced5df63aa9b6b761f (patch)
treee2857c8336cc1dbae087ba4717707bc24b4df2dd /gnu/packages/rdf.scm
parenta413bc8bd3c2c7d00d8d021a2224a59d26765dad (diff)
parent5f6887e839c10f0c905969d07baca4e03f453e82 (diff)
downloadpatches-b9212a5455304661d1e969ced5df63aa9b6b761f.tar
patches-b9212a5455304661d1e969ced5df63aa9b6b761f.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/rdf.scm')
-rw-r--r--gnu/packages/rdf.scm22
1 files changed, 20 insertions, 2 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 96a52fd93a..f26b021e50 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -243,7 +243,16 @@ and triple stores.")
(base32
"1gxbzqsm212wmn8qkdd3lbl6wbv7fwmaf9qh2nxa4yxjbr7mylb4"))))
(build-system waf-build-system)
- (arguments `(#:tests? #f)) ; no check target
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (add-before
+ 'configure 'set-ldflags
+ (lambda* (#:key outputs #:allow-other-keys)
+ (setenv "LDFLAGS"
+ (string-append "-Wl,-rpath="
+ (assoc-ref outputs "out") "/lib")))))))
(home-page "http://drobilla.net/software/serd/")
(synopsis "Library for RDF syntax supporting Turtle and NTriples")
(description
@@ -268,7 +277,16 @@ ideal (e.g. in LV2 implementations or embedded applications).")
(base32
"0rq7vafdv4vsxi6xk9zf5shr59w3kppdhqbj78185rz5gp9kh1dx"))))
(build-system waf-build-system)
- (arguments `(#:tests? #f)) ; no check target
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (add-before
+ 'configure 'set-ldflags
+ (lambda* (#:key outputs #:allow-other-keys)
+ (setenv "LDFLAGS"
+ (string-append "-Wl,-rpath="
+ (assoc-ref outputs "out") "/lib")))))))
(inputs
`(("serd" ,serd)))
(native-inputs