summaryrefslogtreecommitdiff
path: root/gnu/packages/rails.scm
diff options
context:
space:
mode:
authorMatthew Jordan <matthewjordandevops@yandex.com>2016-05-31 07:26:24 -0400
committerBen Woodcroft <donttrustben@gmail.com>2016-06-04 09:15:57 +1000
commit90322fdbe3c60a039224ceded296fc772f4b642e (patch)
tree51be97197351622966f977c14d76af569e4736c5 /gnu/packages/rails.scm
parent1c5ee417f4c05e5937aae0a34c60d574bba197a0 (diff)
downloadpatches-90322fdbe3c60a039224ceded296fc772f4b642e.tar
patches-90322fdbe3c60a039224ceded296fc772f4b642e.tar.gz
gnu: Add ruby-debug-inspector.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * gnu/packages/rails.scm: New file.
Diffstat (limited to 'gnu/packages/rails.scm')
-rw-r--r--gnu/packages/rails.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/rails.scm b/gnu/packages/rails.scm
new file mode 100644
index 0000000000..83abc65237
--- /dev/null
+++ b/gnu/packages/rails.scm
@@ -0,0 +1,57 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages rails)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module (gnu packages ruby)
+ #:use-module (guix build-system ruby))
+
+(define-public ruby-debug-inspector
+ (package
+ (name "ruby-debug-inspector")
+ (version "0.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "debug_inspector" version))
+ (sha256
+ (base32
+ "109761g00dbrw5q0dfnbqg8blfm699z4jj70l4zrgf9mzn7ii50m"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (and
+ (zero? (system* "rake" "compile"))
+ (zero?
+ (system*
+ "ruby" "-Ilib" "-e"
+ (string-append
+ "require 'debug_inspector'; RubyVM::DebugInspector."
+ "open{|dc| p dc.backtrace_locations}")))))))))
+ (synopsis "Ruby wrapper for the MRI 2.0 debug_inspector API")
+ (description
+ "This package provides a Ruby wrapper for the MRI 2.0 debug_inspector
+API.")
+ (home-page
+ "https://github.com/banister/debug_inspector")
+ (license license:expat)))