summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-08-31 16:34:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-31 16:37:56 +0200
commit0e2d6d2698c5fbb0550d103475473b9800264abe (patch)
tree2f3f61ae40bad5d4c74e498b2e6d165f1cbdbd8d /gnu/packages/qt.scm
parent9fc2922794ffaae48e0a7c536e530ea2e0d46cf3 (diff)
downloadpatches-0e2d6d2698c5fbb0550d103475473b9800264abe.tar
patches-0e2d6d2698c5fbb0550d103475473b9800264abe.tar.gz
gnu: Add python-pyqt-without-qtwebkit.
* gnu/packages/qt.scm (python-pyqt-without-qtwebkit): New variable.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index f6eb2831fd..7dfdade979 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1834,6 +1834,15 @@ framework. The bindings are implemented as a set of Python modules and
contain over 620 classes.")
(license license:gpl3)))
+;; XXX: This is useful because qtwebkit does not build reliably at this time.
+;; Ultimately, it would be nicer to have a more modular set of python-pyqt-*
+;; packages that could be used together.
+(define-public python-pyqt-without-qtwebkit
+ (package (inherit python-pyqt)
+ (name "python-pyqt-without-qtwebkit")
+ (inputs
+ (alist-delete "qtwebkit" (package-inputs python-pyqt)))))
+
(define-public python2-pyqt
(package (inherit python-pyqt)
(name "python2-pyqt")