summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2018-11-25 22:30:35 -0600
committerEric Bavier <bavier@member.fsf.org>2018-11-26 19:03:53 -0600
commit0995a5692cb85418b2d5f21c24d46ee4aa9fb7c9 (patch)
tree9f5c87369613f23564d104d71ebf10bdb43c73e6 /gnu/packages/qt.scm
parent152859388613f3ae65793f763f72868147b2a6be (diff)
downloadpatches-0995a5692cb85418b2d5f21c24d46ee4aa9fb7c9.tar
patches-0995a5692cb85418b2d5f21c24d46ee4aa9fb7c9.tar.gz
qtwebkit: Fix pri install directory.
* gnu/packages/qt.scm (qtwebkit)[arguments]: Add "ECM_MKSPECS_INSTALL_DIR" to #:configure-flags.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d487699827..d8860e79a4 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2171,7 +2172,10 @@ different kinds of sliders, and much more.")
#:configure-flags (list ;"-DENABLE_API_TESTS=TRUE"
"-DPORT=Qt"
"-DUSE_LIBHYPHEN=OFF"
- "-DUSE_SYSTEM_MALLOC=ON")))
+ "-DUSE_SYSTEM_MALLOC=ON"
+ ;; XXX: relative dir installs to build dir?
+ (string-append "-DECM_MKSPECS_INSTALL_DIR="
+ %output "/lib/qt5/mkspecs/modules"))))
(home-page "https://www.webkit.org")
(synopsis "Web browser engine and classes to render and interact with web
content")