summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-10-28 01:14:34 +0100
committerLudovic Courtès <ludo@gnu.org>2014-10-28 01:18:50 +0100
commitf47638a3534c99fb8fef501c5827e9e32a6b4a2e (patch)
tree4611841beeff27a83c78b98f776fdcf1a574e789 /gnu/packages/qt.scm
parent2d7bf949277a0889ced8aa486c4ef16cb7cf6b1a (diff)
downloadpatches-f47638a3534c99fb8fef501c5827e9e32a6b4a2e.tar
patches-f47638a3534c99fb8fef501c5827e9e32a6b4a2e.tar.gz
gnu: Mark a few packages as unsupported on MIPS.
* gnu/packages/gprolog.scm (gprolog): Add 'supported-systems' field. * gnu/packages/qemu.scm (qemu-headless): Likewise. * gnu/packages/qt.scm (qt): Likewise. * gnu/packages/scheme.scm (racket): Likewise.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 3df0066c4f..391cfac77e 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -145,7 +145,12 @@ X11 (yet).")
(synopsis "Cross-platform GUI library")
(description "Qt is a cross-platform application and UI framework for
developers using C++ or QML, a CSS & JavaScript like language.")
- (license lgpl2.1)))
+ (license lgpl2.1)
+
+ ;; Qt 4: 'QBasicAtomicPointer' leads to build failures on MIPS;
+ ;; see <http://hydra.gnu.org/build/112828>.
+ ;; Qt 5: assembler error; see <http://hydra.gnu.org/build/112526>.
+ (supported-systems (delete "mips64el-linux" %supported-systems))))
(define-public qt-4
(package (inherit qt)