summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-18 11:54:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-18 11:54:54 +0200
commit993a4fbb7c3d1f9977e0789c21905fddd72241fd (patch)
tree899b928672607b9ad74dafd42eb2bfa048a041c4 /gnu/packages/qt.scm
parent248965c91caf7d10433f090b4712a9b201968416 (diff)
parent7bc46ecc34ceb042ff890e5d306d0a2a736e891d (diff)
downloadpatches-993a4fbb7c3d1f9977e0789c21905fddd72241fd.tar
patches-993a4fbb7c3d1f9977e0789c21905fddd72241fd.tar.gz
Merge remote-tracking branch 'origin/master' into wip-texlive
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 52eb46cce0..165b8fd7b4 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2212,6 +2212,12 @@ time Web content can be enhanced with native controls.")
;; Building QtWebKit takes around 13 hours on an AArch64 machine. Give some
;; room for slower or busy hardware.
(properties '((timeout . 64800))) ;18 hours
+
+ ;; XXX: This consumes too much RAM to successfully build on AArch64 (e.g.,
+ ;; SoftIron OverDrive with 8 GiB of RAM), so instead of wasting resources,
+ ;; disable it on non-Intel platforms.
+ (supported-systems '("x86_64-linux" "i686-linux"))
+
(license license:lgpl2.1+)))
(define-public dotherside