summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-07-22 14:40:29 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-07-22 20:43:01 +0300
commit2338755afae1b54504f4cc410a41c1ccc8493fdf (patch)
tree638d9831ac36773dde72a658f33b34f0130b51fa /gnu/packages/qt.scm
parentfac1447bf377240c7672de48729aa669bf074e19 (diff)
downloadpatches-2338755afae1b54504f4cc410a41c1ccc8493fdf.tar
patches-2338755afae1b54504f4cc410a41c1ccc8493fdf.tar.gz
gnu: python-pyqt: Don't use private sip file.
* gnu/packages/qt.scm (python-sip)[arguments]: Don't use '--sip-module' flag in custom 'configure phase. (python-pyqt)[sources]: Add patch. * gnu/packages/patches/pyqt-public-sip.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 9e02cdccf5..20543fe837 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1632,7 +1632,6 @@ message.")))
python-major+minor
"/site-packages")))
(invoke "python" "configure.py"
- "--sip-module" "PyQt5.sip" ; for python-pyqt
"--bindir" bin
"--destdir" lib
"--incdir" include)))))))
@@ -1671,7 +1670,8 @@ module provides support functions to the automatically generated code.")
(sha256
(base32
"00wn9svgyp0fsrkc4ma15zcxg31pw4gsgaz6nwb3fhy3al8miakw"))
- (patches (search-patches "pyqt-configure.patch"))))
+ (patches (search-patches "pyqt-configure.patch"
+ "pyqt-public-sip.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("qtbase" ,qtbase))) ; for qmake