summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-27 19:09:58 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-27 19:40:13 +0100
commita59e2dd8cd16655e379abb567baf978c94f3d48e (patch)
treeb45ba95cff27eddc9db830f0e670c7b0e09d4bbb /gnu/packages/qt.scm
parentb60d2bfff95c0859d7814c1fe9d0940c87edc2b4 (diff)
downloadpatches-a59e2dd8cd16655e379abb567baf978c94f3d48e.tar
patches-a59e2dd8cd16655e379abb567baf978c94f3d48e.tar.gz
gnu: qtbase: Use absolute references in .prl files.
This fixes <https://bugs.gnu.org/38405>. * gnu/packages/qt.scm (qtbase)[arguments]: Add phase 'patch-prl-files'.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 5f4f29a948..2cc44ab831 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -509,6 +509,16 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(("\\$\\$\\[QT_HOST_DATA/get\\]") archdata)
(("\\$\\$\\[QT_HOST_DATA/src\\]") archdata))
#t)))
+ (add-after 'patch-mkspecs 'patch-prl-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; Insert absolute references to the qtbase libraries because
+ ;; QT_INSTALL_LIBS does not always resolve correctly, depending
+ ;; on context. See <https://bugs.gnu.org/38405>
+ (substitute* (find-files (string-append out "/lib") "\\.prl$")
+ (("\\$\\$\\[QT_INSTALL_LIBS\\]")
+ (string-append out "/lib")))
+ #t)))
(add-after 'unpack 'patch-paths
;; Use the absolute paths for dynamically loaded libs, otherwise
;; the lib will be searched in LD_LIBRARY_PATH which typically is