summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-10-24 20:26:37 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-01 17:04:51 +0100
commit9759dd1a8af33490aad96cf5ff53855618ff25d2 (patch)
treeec6ab5c9089c2554343d49a3bf992d12f661302a /gnu/packages/qt.scm
parent79f0bd7fb3e726883916173390e2704f91aa0c09 (diff)
downloadpatches-9759dd1a8af33490aad96cf5ff53855618ff25d2.tar
patches-9759dd1a8af33490aad96cf5ff53855618ff25d2.tar.gz
gnu: Remove qtdeclarative-render2d.
This module has been merged into qtdeclarative as of Qt 5.8.0 and is not used anywhere.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 929144f30d..e9dc406328 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1434,34 +1434,6 @@ components. The API consists of over 20 effects provided as separate QML
types. The effects cover functional areas such as blending, masking, blurring,
coloring, and many more.")))
-(define-public qtdeclarative-render2d
- ;; As of Qt-5.8.0 this module has been merged into qtdeclarative
- (package (inherit qtsvg)
- (name "qtdeclarative-render2d")
- (version "5.7.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://download.qt.io/official_releases/qt/"
- (version-major+minor version) "/" version
- "/submodules/" name "-everywhere-src-"
- version ".tar.xz"))
- (sha256
- (base32
- "0zwch9vn17f3bpy300jcfxx6cx9qymk5j7khx0x9k1xqid4166c3"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (delete-file-recursively "tools/opengldummy/3rdparty")
- #t))))
- (native-inputs `())
- (inputs
- `(("qtbase" ,qtbase)
- ("qtdeclarative" ,qtdeclarative)))
- (synopsis "Qt Declarative Render module")
- (description "The Qt Declarative Render 2D module provides a Raster
-backend for QtQuick scene graph.")
- (properties `((superseded . ,qtdeclarative)))))
-
(define-public qtgamepad
(package (inherit qtsvg)
(name "qtgamepad")