summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorPkill -9 <pkill9@runbox.com>2019-02-17 09:42:28 +0000
committerRicardo Wurmus <rekado@elephly.net>2019-02-17 12:14:57 +0100
commitb16640ac03ecab228d63f2f887435a04cd6557db (patch)
tree648cc0b362cac52dd27695a69c69a1281e6f4ec0 /gnu/packages/qt.scm
parent451a5ae9ba124834e5397593b606ea548cfe5f88 (diff)
downloadpatches-b16640ac03ecab228d63f2f887435a04cd6557db.tar
patches-b16640ac03ecab228d63f2f887435a04cd6557db.tar.gz
gnu: Add qtcolorwidgets.
* gnu/packages/qt.scm (qtcolorwidgets): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 664309cb52..8179911539 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2232,3 +2232,33 @@ a binding language:
@item Creating from Singleton QML QObject defined in the binded language
@end itemize\n")
(license license:lgpl3))) ;version 3 only (+ exception)
+
+;; There have been no public releases yet.
+(define-public qtcolorwidgets
+ (let ((commit "a95f72e935fe9e046061a1d1c3930cbfbcb533e0")
+ (revision "1"))
+ (package
+ (name "qtcolorwidgets")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/mattia.basaglia/Qt-Color-Widgets")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0dkiwlqh2gwhlp78c1fmchj3shl4p9inspcl96ya5aa8mn6kydy8"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; There are no tests
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (home-page "https://gitlab.com/mattia.basaglia/Qt-Color-Widgets")
+ (synopsis "Color management widgets")
+ (description "QtColorWidgets provides a Qt color dialog that is more
+user-friendly than the default @code{QColorDialog} and several other
+color-related widgets.")
+ ;; Includes a license exception for combining with GPL2 code.
+ (license license:lgpl3+))))