summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-02 16:04:17 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-02 19:53:03 +0200
commit2879e605bfa59fe33e78f6a425fee70dcebaac38 (patch)
treef0a023c612814b2c613ba8bb9628355a57abb3e1 /gnu/packages/qt.scm
parent9fb5771af76123cfecee83da677cb7fb7a6c810c (diff)
downloadpatches-2879e605bfa59fe33e78f6a425fee70dcebaac38.tar
patches-2879e605bfa59fe33e78f6a425fee70dcebaac38.tar.gz
gnu: qtkeychain: Update to 0.9.1.
* gnu/packages/qt.scm (qtkeychain): Update to 0.9.1. [source]: Use 'git-fetch'. [arguments]: Update custom 'set-qt-trans-dir phase.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 2b8b5923aa..1c460e5957 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015, 2018 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
@@ -31,6 +31,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build utils)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
@@ -2026,15 +2027,17 @@ This package provides the Python bindings.")))
(define-public qtkeychain
(package
(name "qtkeychain")
- (version "0.8.0")
+ (version "0.9.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/frankosterfeld/qtkeychain/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/frankosterfeld/qtkeychain/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0bxi5pfhxdvwk8yxa06lk2d7lcibmfqhahbin82bqf3m341zd4ml"))))
+ (base32
+ "0h4wgngn2yl35hapbjs24amkjfbzsvnna4ixfhn87snjnq5lmjbc"))))
(build-system cmake-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -2045,12 +2048,11 @@ This package provides the Python bindings.")))
`(#:tests? #f ; No tests included
#:phases
(modify-phases %standard-phases
- (add-before
- 'configure 'set-qt-trans-dir
+ (add-before 'configure 'set-qt-trans-dir
(lambda _
(substitute* "CMakeLists.txt"
(("\\$\\{qt_translations_dir\\}")
- "${CMAKE_INSTALL_PREFIX}/share/qt/translations"))
+ "${CMAKE_INSTALL_PREFIX}/share/qt5/translations"))
#t)))))
(home-page "https://github.com/frankosterfeld/qtkeychain")
(synopsis "Qt API to store passwords")