summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2017-09-07 21:19:54 +0800
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-13 13:53:39 +0200
commit163651cbdc7b28bb7417a4e45cf885e42b7f5af0 (patch)
treed476903c1f69e859b2c22b86e29ed97941f98477 /gnu/packages/qt.scm
parent8075b623786f11966febac7d4ac0f5e90e3f7712 (diff)
downloadpatches-163651cbdc7b28bb7417a4e45cf885e42b7f5af0.tar
patches-163651cbdc7b28bb7417a4e45cf885e42b7f5af0.tar.gz
gnu: qwt: Adjust installation directory layout.
* gnu/packages/qt.scm (qwt)[arguments]<#:phases>: Modify 'qwtconfig.pri' to use a directory layout that matching qtbase. Modify 'doc/doc.pro' to remove the misplaced installation of man pages. Rename phase 'install-documentation' to 'install-man-pages'.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm22
1 files changed, 19 insertions, 3 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 7efce6b5a6..0f911dc783 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1806,11 +1806,27 @@ securely. It will not store any data unencrypted unless explicitly requested.")
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
+ (let* ((out (assoc-ref outputs "out"))
+ (docdir (string-append out "/share/doc/qwt"))
+ (incdir (string-append out "/include/qwt"))
+ (pluginsdir (string-append out "/lib/qt5/plugins/designer"))
+ (featuresdir (string-append out "/lib/qt5/mkspecs/features")))
(substitute* '("qwtconfig.pri")
- (("/usr/local/qwt-\\$\\$QWT\\_VERSION") out))
+ (("^(\\s*QWT_INSTALL_PREFIX)\\s*=.*" _ x)
+ (format #f "~a = ~a\n" x out))
+ (("^(QWT_INSTALL_DOCS)\\s*=.*" _ x)
+ (format #f "~a = ~a\n" x docdir))
+ (("^(QWT_INSTALL_HEADERS)\\s*=.*" _ x)
+ (format #f "~a = ~a\n" x incdir))
+ (("^(QWT_INSTALL_PLUGINS)\\s*=.*" _ x)
+ (format #f "~a = ~a\n" x pluginsdir))
+ (("^(QWT_INSTALL_FEATURES)\\s*=.*" _ x)
+ (format #f "~a = ~a\n" x featuresdir)))
+ (substitute* '("doc/doc.pro")
+ ;; We'll install them in the 'install-man-pages' phase.
+ (("^unix:doc\\.files.*") ""))
(zero? (system* "qmake")))))
- (add-after 'install 'install-documentation
+ (add-after 'install 'install-man-pages
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(man (string-append out "/share/man")))