summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2016-01-25 23:33:54 +0100
committerAndreas Enge <andreas@enge.fr>2016-01-25 23:33:54 +0100
commit46854e99caadcaaa282be1093e3ea6454667cac3 (patch)
tree541db463b3e5ce518d7ad5956d47da516c69308c /gnu/packages/qt.scm
parent412bee5e2931a53066ae593808935608d54a4345 (diff)
downloadpatches-46854e99caadcaaa282be1093e3ea6454667cac3.tar
patches-46854e99caadcaaa282be1093e3ea6454667cac3.tar.gz
gnu: webkitgtk-2.4, webkitgtk/gtk+-2, qt: Disable parallel builds.
* gnu/packages/webkit.scm (webkitgtk-2.4, webkitgtk/gtk+-2): Disable parallel builds as suggested in https://lists.gnu.org/archive/html/guix-devel/2016-01/msg00837.html . * gnu/packages/qt.scm (qt): Likewise.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 8f148c9e90..dccc9a2e48 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -182,7 +182,12 @@ X11 (yet).")
("ruby" ,ruby)
("which" ,(@ (gnu packages base) which))))
(arguments
- `(#:phases
+ `(;; FIXME: Disabling parallel building is a quick hack to avoid the
+ ;; failure described in
+ ;; https://lists.gnu.org/archive/html/guix-devel/2016-01/msg00837.html
+ ;; A more structural fix is needed.
+ #:parallel-build? #f
+ #:phases
(alist-replace
'configure
(lambda* (#:key outputs #:allow-other-keys)