summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-02-10 12:10:17 +0100
committerLudovic Courtès <ludo@gnu.org>2019-02-10 23:25:01 +0100
commitb717d0f90eed10c1173ba10b30db82d502b5b9df (patch)
treec8b4727747402c1d41532ee7bc692c514ca17e36 /gnu/packages/qt.scm
parent2356b7ab6d36522880abb7073ec87990b721ce1a (diff)
downloadpatches-b717d0f90eed10c1173ba10b30db82d502b5b9df.tar
patches-b717d0f90eed10c1173ba10b30db82d502b5b9df.tar.gz
gnu: qtwebkit: Build sequentially.
Fixes <https://bugs.gnu.org/34062>. * gnu/packages/qt.scm (qtwebkit)[arguments]: Add #:parallel-build? #f.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 2e8f2d1135..6775a991b9 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2173,6 +2173,11 @@ different kinds of sliders, and much more.")
(arguments
`(#:tests? #f ; no apparent tests; it might be necessary to set
; ENABLE_API_TESTS, see CMakeLists.txt
+
+ ;; Parallel builds fail due to a race condition:
+ ;; <https://bugs.gnu.org/34062>.
+ #:parallel-build? #f
+
#:configure-flags (list ;"-DENABLE_API_TESTS=TRUE"
"-DPORT=Qt"
"-DUSE_LIBHYPHEN=OFF"