summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-14 12:57:21 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-14 12:57:21 +0100
commitaebba13c0bef5a58697f1a9fe8337967cc01300f (patch)
tree12156f0f2312df613cc554a220a6fd75450aa508 /gnu/packages/qt.scm
parent747953c430039055140e29546ff50641da1ab440 (diff)
parentbb4674b43fa413a6d41694b2093c3b00d11eea47 (diff)
downloadpatches-aebba13c0bef5a58697f1a9fe8337967cc01300f.tar
patches-aebba13c0bef5a58697f1a9fe8337967cc01300f.tar.gz
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm18
1 files changed, 2 insertions, 16 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 7aa9d0f0f9..6642ed6e77 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -351,7 +351,8 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(base32
"0pb68d30clksdhgy8n6rrs838bb3qcsfq4pv463yy2nr4p5kk2di"))
;; Use TZDIR to avoid depending on package "tzdata".
- (patches (search-patches "qtbase-use-TZDIR.patch"))
+ (patches (search-patches "qtbase-use-TZDIR.patch"
+ "qtbase-QTBUG-81715.patch"))
(modules '((guix build utils)))
(snippet
;; corelib uses bundled harfbuzz, md4, md5, sha3
@@ -598,24 +599,9 @@ developers using C++ or QML, a CSS & JavaScript like language.")
developers using C++ or QML, a CSS & JavaScript like language.")
(license (list license:lgpl2.1 license:lgpl3))))
-;; This variant fixes a problem with the CMake macros shipped by qtbase. See
-;; discussion at <https://lists.gnu.org/archive/html/guix-devel/2020-02/msg00308.html>.
-(define-public qtbase-patched
- (let ((src (package-source qtbase)))
- (hidden-package
- (package
- (inherit qtbase)
- (source
- (origin
- (inherit src)
- (patches
- (append (search-patches "qtbase-QTBUG-81715.patch")
- (origin-patches src)))))))))
-
;; qt used to refer to the monolithic Qt 5.x package
(define-deprecated qt qtbase)
-
(define-public qtsvg
(package (inherit qtbase)
(name "qtsvg")