summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-02 13:37:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-02 16:33:56 +0100
commit464cb5b55de70a28e9c42ef6e8a1f84ba5918d90 (patch)
treefcf1d8b8d5816d6c8408253dbd24ed17b5dd37e8 /gnu/packages/python.scm
parent80486d6673c09bc350a79f9c9dc82d88019e8662 (diff)
downloadpatches-464cb5b55de70a28e9c42ef6e8a1f84ba5918d90.tar
patches-464cb5b55de70a28e9c42ef6e8a1f84ba5918d90.tar.gz
gnu: Add python-prompt-toolkit-1.
* gnu/packages/python.scm (python-prompt-toolkit-1, python2-prompt-toolkit-1): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 20b1ff69f0..8c091c0fa3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9929,6 +9929,20 @@ characters, mouse support, and auto suggestions.")
(define-public python2-prompt-toolkit
(package-with-python2 python-prompt-toolkit))
+(define-public python-prompt-toolkit-1
+ (package (inherit python-prompt-toolkit)
+ (version "1.0.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "prompt_toolkit" version ".tar.gz"))
+ (sha256
+ (base32
+ "05v9h5nydljwpj5nm8n804ms0glajwfy1zagrzqrg91wk3qqi1c5"))))))
+
+(define-public python2-prompt-toolkit-1
+ (package-with-python2 python-prompt-toolkit-1))
+
(define-public python-jedi
(package
(name "python-jedi")