summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-02 12:47:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-02 16:33:56 +0100
commitec933e05a20cc70d23f576c5763d6c69eb8452eb (patch)
treeeb522f112601a61a01b4ed8f0fa737e04b1c6464 /gnu/packages/python.scm
parentcd70798a23750dba18266c0e551c68b7ef1b118b (diff)
downloadpatches-ec933e05a20cc70d23f576c5763d6c69eb8452eb.tar
patches-ec933e05a20cc70d23f576c5763d6c69eb8452eb.tar.gz
gnu: python-configargparse: Use INVOKE.
* gnu/packages/python.scm (python-configargparse)[arguments]: Use INVOKE.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ebf56326e1..76ac5bc2fc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7455,7 +7455,7 @@ config files.")
;; NOTE: Many tests do not run because they rely on Python's
;; built-in test.test_argparse, but we remove the unit tests from
;; our Python installation.
- (zero? (system* "python" "setup.py" "test")))))))
+ (invoke "python" "setup.py" "test"))))))
(synopsis "Replacement for argparse")
(description "A drop-in replacement for argparse that allows options to also
be set via config files and/or environment variables.")