summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-03 20:47:39 +0000
committerChristopher Baines <mail@cbaines.net>2019-01-21 19:51:41 +0000
commitd453b0e11d3f001a8160a7d126fdbf40e45d5042 (patch)
tree1474ffb4e8da5b7d6e3bf7c78f65fcf9d23b226c /gnu/packages/python.scm
parent4929ee9b196b7e3f0e4e217865ca4d6dfd22c853 (diff)
downloadpatches-d453b0e11d3f001a8160a7d126fdbf40e45d5042.tar
patches-d453b0e11d3f001a8160a7d126fdbf40e45d5042.tar.gz
gnu: python-2.7: Include /lib/python.../test/support.
Don't remove the support directory from the /lib/python.../test/ directory, as this is used from the test_support module. /gnu/store/...-python2-2.7.15/lib/python2.7/test/test_support.py:2: in <module> import test.support E ImportError: No module named support * gnu/packages/python.scm (python-2.7)[arguments]: Change the 'remove-tests phase to not remove the support directory.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c0ed19e16c..d13d7dbd8d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -271,12 +271,9 @@
(scandir testdir
(match-lambda
((or "." "..") #f)
+ ("support" #f)
(file
(not
- ;; FIXME: Add the 'support' directory
- ;; in the next rebuild cycle, since it
- ;; moved in 2.7.14. See also
- ;; python2-futures below.
(string-prefix? "test_support."
file))))))
(call-with-output-file "__init__.py" (const #t))