summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-03 21:06:44 +0000
committerChristopher Baines <mail@cbaines.net>2019-01-21 19:51:52 +0000
commit85e457946917004cf1ae4f01ea2d51e028884333 (patch)
treee390341f02c764f4fdbd49633ce0b5112908d93e /gnu/packages/python.scm
parentd453b0e11d3f001a8160a7d126fdbf40e45d5042 (diff)
downloadpatches-85e457946917004cf1ae4f01ea2d51e028884333.tar
patches-85e457946917004cf1ae4f01ea2d51e028884333.tar.gz
gnu: python-futures: Enable tests.
Re-enable the tests, as the python-2 package now has the support directory. Also, switch to running the tests via the test_futures.py script to avoid errors like: AttributeError: 'AsCompletedTests' object has no attribute 'executor' * gnu/packages/python.scm (python2-futures)[arguments]: Run the test_futures.py script to run the tests.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d13d7dbd8d..e8706ff688 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7899,11 +7899,14 @@ otherwise matches 3.2’s API.")
(base32
"0rdjmmsab550kxsssdq49jcniz77zlkpw4pvi9hvib3lsskjmh4y"))))
(build-system python-build-system)
- (arguments `(#:python ,python-2
- ;; FIXME: Python 2.7.14 moved the test.support library,
- ;; but our package has not yet been adjusted. Enable
- ;; tests when the python2 package has been fixed.
- #:tests? #f))
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "test_futures.py")
+ #t)))))
(home-page "https://github.com/agronholm/pythonfutures")
(synopsis
"Backport of the concurrent.futures package from Python 3.2")