summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-24 13:56:42 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-10-23 17:11:03 +0200
commit5176795d22860c18015e36b7a9d3b8729b6729f1 (patch)
tree24dbe9530772080ab497faffc6c23b584353fdec /gnu/packages/python.scm
parent78da6977c738824d730803cb918137d5fe6cbbce (diff)
downloadpatches-5176795d22860c18015e36b7a9d3b8729b6729f1.tar
patches-5176795d22860c18015e36b7a9d3b8729b6729f1.tar.gz
gnu: Add python-pympler.
* gnu/packages/python.scm (python-pympler, python2-pympler): New public variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 66d587cc52..42097b889c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2177,6 +2177,42 @@ easier to build concurrent applications.")
(define-public python2-pykka
(package-with-python2 python-pykka))
+(define-public python-pympler
+ (package
+ (name "python-pympler")
+ (home-page "https://pythonhosted.org/Pympler/")
+ (version "0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Pympler" version))
+ (sha256
+ (base32
+ "03qwsbilqgvnbl3a1jmpgixbr2kq6m3fvdlzyr3wdp01bwlc85kx"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "setup.py" "test"))))))
+ (synopsis "Measure, monitor and analyze memory behavior")
+ (description
+ "Pympler is a development tool to measure, monitor and analyze
+the memory behavior of Python objects in a running Python application.
+
+By pympling a Python application, detailed insight in the size and the
+lifetime of Python objects can be obtained. Undesirable or unexpected
+runtime behavior like memory bloat and other @samp{pymples} can easily
+be identified.
+
+A web profiling frontend exposes process statistics, garbage
+visualisation and class tracker statistics.")
+ (license license:asl2.0)))
+
+(define-public python2-pympler
+ (package-with-python2 python-pympler))
+
(define-public python-itsdangerous
(package
(name "python-itsdangerous")