summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-21 19:37:01 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-10-23 00:35:05 +0200
commit4cdbffdc2fa5f90b7c0231d7d68de8f2d4a4dbed (patch)
treeb52d7757c427a7bf803f71ce63602931532c3cd7 /gnu/packages/python.scm
parent3a23036a0a8fb51b56ec88a06c64bf546f97032b (diff)
downloadpatches-4cdbffdc2fa5f90b7c0231d7d68de8f2d4a4dbed.tar
patches-4cdbffdc2fa5f90b7c0231d7d68de8f2d4a4dbed.tar.gz
gnu: python-stem: Update to 1.7.0.
* gnu/packages/python.scm (python-stem): Update to 1.7.0. [arguments]: Remove obsolete phase. [native-inputs]: Change PYTHON-PEP8 to PYTHON-PYCODESTYLE.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a1718c73b1..66d587cc52 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9763,32 +9763,25 @@ etc.")
(define-public python-stem
(package
(name "python-stem")
- (version "1.6.0")
+ (version "1.7.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "stem" version))
(sha256
(base32
- "1va9p3ij7lxg6ixfsvaql06dn11l3fgpxmss1dhlvafm7sqizznp"))))
+ "1awiglfiajnx2hva9aqpj3fmdvdb4qg7cwnlfyih827m68y3cq8v"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'check 'fix-test-environment
- (lambda _
- ;; Fixes: FileNotFoundError: [Errno 2] No such file or directory:
- ;; '/tmp/guix-build-python-stem-1.6.0.drv-0/stem-1.6.0/.gitignore'.
- (with-output-to-file ".gitignore"
- (lambda _ (format #t "%")))
- #t))
(replace 'check
(lambda _
(invoke "./run_tests.py" "--unit")
#t)))))
(native-inputs
`(("python-mock" ,python-mock)
- ("python-pep8" ,python-pep8)
+ ("python-pycodestyle" ,python-pycodestyle)
("python-pyflakes" ,python-pyflakes)))
(home-page "https://stem.torproject.org/")
(synopsis