summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-05-25 17:19:04 -0400
committerLeo Famulari <leo@famulari.name>2017-05-26 14:47:42 -0400
commitc0f5b8029521d86943b1d43f7dd620c7ba98b605 (patch)
tree3af46e31408dc803f76c08c36359eb75c0c8cb8c /gnu/packages/python.scm
parent8347c12291ca2234dfdee87074e305793d71f787 (diff)
downloadpatches-c0f5b8029521d86943b1d43f7dd620c7ba98b605.tar
patches-c0f5b8029521d86943b1d43f7dd620c7ba98b605.tar.gz
gnu: Add python-packaging.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4690a43a23..455dd0b29f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14767,3 +14767,35 @@ for Flask programs that are using @code{python-alembic}.")
(define-public python2-flask-migrate
(package-with-python2 python-flask-migrate))
+
+(define-public python-packaging
+ (package
+ (name "python-packaging")
+ (version "16.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "packaging" version))
+ (sha256
+ (base32
+ "17k1xbjshackwvbsnxqixbph8rbqhz4bf4g3al5xyzhavxgq6l2x"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pretend" ,python-pretend)
+ ("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-pyparsing" ,python-pyparsing)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/pypa/packaging")
+ (synopsis "Core utilities for Python packages")
+ (description "Packaging is a Python module for dealing with Python packages.
+It offers an interface for working with package versions, names, and dependency
+information.")
+ ;; From 'LICENSE': This software is made available under the terms of
+ ;; *either* of the licenses found in LICENSE.APACHE or LICENSE.BSD.
+ ;; Contributions to this software is made under the terms of *both* these
+ ;; licenses.
+ (license (list license:asl2.0 license:bsd-2))))
+
+(define-public python2-packaging
+ (package-with-python2 python-packaging))