summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-05-28 18:32:41 +0300
committerMarius Bakke <mbakke@fastmail.com>2017-06-04 14:48:18 +0200
commit7e488f9991cfec1ef9e8ca5d1910a65920ab2750 (patch)
tree764514d099734ba94077f6b4d9219ef23a79dac8 /gnu/packages/python.scm
parent5786b47c7ef8a21592281fa60adaf95bb0041be1 (diff)
downloadpatches-7e488f9991cfec1ef9e8ca5d1910a65920ab2750.tar
patches-7e488f9991cfec1ef9e8ca5d1910a65920ab2750.tar.gz
gnu: Add python-nose-randomly.
* gnu/packages/python.scm (python-nose-randomly, python2-nose-randomly): New variables. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ee216116cc..07f4f812c7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15050,3 +15050,32 @@ markdown. The documentation may contain snippets of code surrounded by python
code blocks and @code{Steadymark} will find these snippets and run them, making
sure that there are no old malfunctional examples in the documentation examples.")
(license license:expat)))
+
+(define-public python-nose-randomly
+ (package
+ (name "python-nose-randomly")
+ (version "1.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nose-randomly" version))
+ (sha256
+ (base32
+ "1cw9dlr1zh3w4i438kin7z0rm8092ki52hayisyc43h9pcplq7rn"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-numpy" ,python-numpy)))
+ (home-page "https://github.com/adamchainz/nose-randomly")
+ (synopsis
+ "Nose plugin to randomly order tests and control random.seed")
+ (description
+ "This is a @code{Nose} plugin to randomly order tests which can be quite
+powerful in discovering hidden flaws in the tests themselves, while helping to
+reduce inter-test dependencies. It also helps in controlling @code{random.seed},
+by resetting it to a repeatable number for each test, enabling the tests to
+create data based on random numbers and yet remain repeatable.")
+ (license license:bsd-3)))
+
+(define-public python2-nose-randomly
+ (package-with-python2 python-nose-randomly))