summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-03-13 17:11:19 -0400
committerLeo Famulari <leo@famulari.name>2017-03-14 02:45:23 -0400
commitdc5cec21f275a023a2793befb692a0dc193ed88a (patch)
treefbbdba07af5b59d52320d7db55df10bcf138fe12 /gnu/packages/python.scm
parent3f9543aee1e49001d0f80542dd71ba73c44787c7 (diff)
downloadpatches-dc5cec21f275a023a2793befb692a0dc193ed88a.tar
patches-dc5cec21f275a023a2793befb692a0dc193ed88a.tar.gz
gnu: python@2.7: Fix getentropy() calls on kernels < 3.17.
* gnu/packages/patches/python-2.7-getentropy-on-old-kernels.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python.scm (python-2.7)[source]: Use it.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5baf329995..1f375621f6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -133,7 +133,8 @@
(patches (search-patches "python-2.7-search-paths.patch"
"python-2-deterministic-build-info.patch"
"python-2.7-site-prefixes.patch"
- "python-2.7-source-date-epoch.patch"))
+ "python-2.7-source-date-epoch.patch"
+ "python-2.7-getentropy-on-old-kernels.patch"))
(modules '((guix build utils)))
;; suboptimal to delete failing tests here, but if we delete them in the
;; arguments then we need to make sure to strip out that phase when it