summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-08-26 15:15:49 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-08-26 15:15:49 +0200
commit72e2815d18ad688b0a16ce3b3efba1172423cec4 (patch)
treeb3d6aa01aec86a7f224e15d97a40b64de4e5cdb8 /gnu/packages/python.scm
parentc20cd0d24d9b5e8a47b864db9799e0992ffd44b9 (diff)
parent2f837cf7fe100b0584fb02cf8f19d4cfb4e14d88 (diff)
downloadpatches-72e2815d18ad688b0a16ce3b3efba1172423cec4.tar
patches-72e2815d18ad688b0a16ce3b3efba1172423cec4.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 14 insertions, 12 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4bd777c09e..6fe83b2a8b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -344,8 +344,11 @@ data types.")
(base32
"1c6v1n9nz4mlx9mw1125fxpmbrgniqdbbx9hnqx44maqazb2mzpf"))
(snippet
- '(delete-file
- "Lib/ctypes/test/test_win32.py")))) ; fails on aarch64
+ '(begin
+ (for-each delete-file
+ '("Lib/ctypes/test/test_win32.py" ; fails on aarch64
+ "Lib/test/test_fcntl.py"))
+ #t))))
(arguments (substitute-keyword-arguments (package-arguments python-2)
((#:tests? _) #t)))
(native-search-paths
@@ -1900,7 +1903,9 @@ code introspection, and logging.")
(propagated-inputs
`(("python-py" ,python-py)))
(native-inputs
- `(("python-nose" ,python-nose)
+ `(;; Tests need the "regular" bash since 'bash-final' lacks `compgen`.
+ ("bash" ,bash)
+ ("python-nose" ,python-nose)
("python-mock" ,python-mock)))
(home-page "http://pytest.org")
(synopsis "Python testing library")
@@ -1937,9 +1942,8 @@ and many external plugins.")
line)))
#t)))))
(native-inputs
- `(("python-nose" ,python-nose)
- ("python-mock" ,python-mock)
- ("python-hypothesis" ,python-hypothesis)))
+ `(("python-hypothesis" ,python-hypothesis)
+ ,@(package-native-inputs python-pytest)))
(properties `((python2-variant . ,(delay python2-pytest-3.0))))))
(define-public python2-pytest-3.0
@@ -5306,7 +5310,8 @@ displayed.")
`(("python-nose" ,python-nose)
("python-pytest" ,python-pytest-3.0)
("man-db" ,man-db)
- ("which" ,which)))
+ ("which" ,which)
+ ("bash-full" ,bash))) ;full Bash for 'test_replwrap.py'
(propagated-inputs
`(("python-ptyprocess" ,python-ptyprocess)))
(home-page "http://pexpect.readthedocs.org/")
@@ -7979,10 +7984,6 @@ Python's @code{ctypes} foreign function interface (FFI).")
(package
(inherit file)
(name "python-file")
- (source (origin
- (inherit (package-source file))
- ;; This patch should not be applied to python2-file.
- (patches (search-patches "python-file-double-encoding-bug.patch"))))
(build-system python-build-system)
(arguments
'(#:tests? #f ;no tests
@@ -13596,7 +13597,8 @@ specs from your Flask-Restful projects.")
(build-system python-build-system)
(native-inputs
`(("python-pexpect" ,python-pexpect)
- ("tcsh" ,tcsh)))
+ ("tcsh" ,tcsh)
+ ("bash-full" ,bash))) ;full Bash for 'test_file_completion'
(home-page "https://github.com/kislyuk/argcomplete")
(synopsis "Shell tab completion for Python argparse")
(description "argcomplete provides extensible command line tab completion