summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2017-07-22 14:23:18 +0200
committerJelle Licht <jlicht@fsfe.org>2017-09-11 01:12:59 +0200
commitcfd34f43164b68ddc91cc051f72f2d3fe5a0ab40 (patch)
tree346ad6c94d19edb51f2bafe5bddbb1bf9df42f28 /gnu/packages/python.scm
parentc1b815a5b8b0c47f05238c03680c1b9d687a9825 (diff)
downloadpatches-cfd34f43164b68ddc91cc051f72f2d3fe5a0ab40.tar
patches-cfd34f43164b68ddc91cc051f72f2d3fe5a0ab40.tar.gz
gnu: python-apsw: Build with all extensions.
* gnu/packages/python.scm (python-apsw)[phases]: Replace build phase; add flag to build all extensions. Add build-test-helper to allow testing of extensions.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d3df1ac5c5..d7156bf518 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6237,6 +6237,16 @@ implementation of D-Bus.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (replace 'build
+ (lambda _
+ (zero?
+ (system* "python" "setup.py" "build" "--enable-all-extensions"))))
+ (add-after 'build 'build-test-helper
+ (lambda _
+ (zero?
+ (system
+ (string-append "gcc -fPIC -shared -o ./testextension.sqlext "
+ "-I. -Isqlite3 src/testextension.c") ))))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key inputs outputs #:allow-other-keys)