summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2017-09-14 21:43:51 +0200
committerLudovic Courtès <ludo@gnu.org>2017-09-15 18:31:53 +0200
commit24d158136fa8ec56a643bf707c2563d9721ed806 (patch)
treec8d2e055d86e2cd293d252d47ff238b1e89dd94a /gnu/packages/python.scm
parent893f9d240a0a8b7b9f02a08d030618b15126554d (diff)
downloadpatches-24d158136fa8ec56a643bf707c2563d9721ed806.tar
patches-24d158136fa8ec56a643bf707c2563d9721ed806.tar.gz
gnu: Add python-schedule.
* gnu/packages/python.scm (python-schedule, python2-schedule): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6c76df7b8b..5927db0d66 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1249,6 +1249,33 @@ datetime module, available in Python 2.3+.")
(define-public python2-parsedatetime
(package-with-python2 python-parsedatetime))
+(define-public python-schedule
+ (package
+ (name "python-schedule")
+ (version "0.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "schedule" version))
+ (sha256
+ (base32
+ "0vplyjcbfrq50sphlwya749z8p2pcyi2nycw3518i0qpd9a6189i"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-mock" ,python-mock)))
+ (home-page "https://github.com/dbader/schedule")
+ (synopsis "Schedule periodic function calls in Python")
+ (description
+ "Schedule is an in-process scheduler for periodic jobs that uses the
+builder pattern for configuration. Schedule lets you run Python functions (or
+any other callable) periodically at pre-determined intervals using a simple,
+human-friendly syntax.")
+ (license license:expat)))
+
+(define-public python2-schedule
+ (package-with-python2 python-schedule))
+
(define-public python-pandas
(package
(name "python-pandas")