summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2017-11-28 14:48:08 -0500
committerLeo Famulari <leo@famulari.name>2017-11-28 14:49:08 -0500
commita39211febd46fdc7c55340693abe1e7dd1110dbb (patch)
tree337921965282995905e0defbc5e41c9c9dad2f58 /gnu/packages/python.scm
parent9b3c7520eb8fde918660745ded8dc0574f019442 (diff)
downloadpatches-a39211febd46fdc7c55340693abe1e7dd1110dbb.tar
patches-a39211febd46fdc7c55340693abe1e7dd1110dbb.tar.gz
gnu: Add python-pyclipper.
* gnu/packages/python.scm (python-pyclipper, python2-pyclipper): New variables. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f5575034da..9bff57a562 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11883,3 +11883,31 @@ belong to tagged versions.")
(define-public python2-setuptools-scm-git-archive
(package-with-python2 python-setuptools-scm-git-archive))
+
+(define-public python-pyclipper
+ (package
+ (name "python-pyclipper")
+ (version "1.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyclipper" version ".zip"))
+ (sha256
+ (base32
+ "1zpmwv3bya3j984y5cf9x9d5108kf6mxldcba68wiq0frv5qrssw"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)); 8 Tests fail, 37 succeed
+ (propagated-inputs
+ `(("python-setuptools-scm-git-archive" ,python-setuptools-scm-git-archive)))
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (home-page "https://github.com/greginvm/pyclipper")
+ (synopsis "Wrapper for Angus Johnson's Clipper library")
+ (description
+ "Pyclipper is a Cython wrapper for the C++ translation of the
+ Angus Johnson's polygon clipping Clipper library (ver. 6.2.1).")
+ (license license:expat)))
+
+(define-public python2-pyclipper
+ (package-with-python2 python-pyclipper))