summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-12-03 16:04:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-01-17 22:37:04 +0200
commit1abe448d56d415a4b9280a22741112f8436a6a0a (patch)
tree3cc3d83000097f7cd120f277b54baf7cdd4b349c /gnu/packages/python.scm
parent5988c299c4bf8d7adf399a885849db7c99b668df (diff)
downloadpatches-1abe448d56d415a4b9280a22741112f8436a6a0a.tar
patches-1abe448d56d415a4b9280a22741112f8436a6a0a.tar.gz
gnu: Add python2-functools32.
* gnu/packages/python.scm (python2-functools32): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 76589ff43c..8358c8890b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7144,6 +7144,31 @@ authenticated session objects providing things like keep-alive.")
`(("python2-unittest2", python2-unittest2)
,@(package-native-inputs rauth))))))
+(define-public python2-functools32
+ (package
+ (name "python2-functools32")
+ (version "3.2.3-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "functools32" version))
+ (sha256
+ (base32
+ "0v8ya0b58x47wp216n1zamimv4iw57cxz3xxhzix52jkw3xks9gn"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ #:tests? #f)) ; no test target
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)))
+ (home-page "https://github.com/MiCHiLU/python-functools32")
+ (synopsis
+ "Backport of the functools module from Python 3.2.3")
+ (description
+ "This package is a backport of the @code{functools} module from Python
+3.2.3 for use with older versions of Python and PyPy.")
+ (license license:expat)))
+
(define-public python-futures
(package
(name "python-futures")